Q

App cannot be downloaded even though the operating environment is met.
Compatibility
Data Transfer

A

"Tales of Crestria" requires iPhone 5s and iOS 10 or later.

If you cannot download the app, please check your device and OS version again.

* Even if the above conditions are met, it may not be available on some devices.
*When upgrading the OS version, please note that that is at your own risk.

Return to top of search page