• What OS are supported?
    Compatibility
    (As of May 16, 2018)

    Recommended OS Version:

    Android 4.4 or later

    Was this QA useful? useful useless Thank You

Relation Title